Triumph Speed Four – Problem with Regulator Rectifier / Alternator / Stator… | Motorcycles catalog with specifications, pictures, ratings, reviews and discusssions

Triumph Speed Four – Problem with Regulator Rectifier / Alternator / Stator…

11 Mar 2015 | Author: | Comments Off on Triumph Speed Four – Problem with Regulator Rectifier / Alternator / Stator…
Triumph Speed Four

Triumph Speed Four – Problem with Regulator Rectifier / Alternator / Stator / Corroded Wiring Problem

I have been having a few issues with my Triumph Speed Four motorbike.

The Problem:

Sometimes I have difficulty on starting the bike. Once I was at a friends house and I could not start the bike so I tried my best to roll it down a hill and put the ignition on and put it into gear two and pressing the clutch and also turning the throttle a bit whilst pressing the startup/ignition button. After one bump start tempt the bike started straight away and off I went home.

I then had a similar problem I had to jump start the bike connecting it to a battery jump pack. I got the bike going and rode a few miles. I noticed the speedo was flashing all the digits on and off and the indicators were flashing rapidly even thou no bulbs had blown. I kept riding a little more and as I revved the bike or put a bit more throttle down and gained speed the speedo and indicators operated normally again.

I then sat in some roadworks (Common in the UK) and the bike seemed to have trouble with the revs at idle. Sounded like it was about to stall. A orange light appeared on the dash which was the engine management light.

I thought maybe its something serious so was going to pull over shortly but the bike ended up turning itself off whilst I was going along and forced me to pull over. I could no longer start the bike it sounded like a clicking noise which made me think the battery was flat which was correct. I was then recovered after about 3 hours waiting for a recovery van to come collect me and take me 2 or 3 miles back to my home.

Unfortunately he had to come from Portsmouth which is about 55 miles away so took him ages.

The recovery man believed it was a faulty battery or a problem with the regulator rectifier or a more uncommon problem which is the alternator.

I took it to the garage I purchased it from “Motorcycle Trade Ins” In Poole and they had a look at it and told me it was the battery and the DataTool alarms flatten the battery so quickly. They said they may have to remove the DataTool alarm from the bike for £45 removal fee. If that was not the problem then it would be the battery and that would be £55.

I stated I did not want the alarm removed if the alarm appeared to be the issue because I may be able to solve this with a friend. The guy replied saying he has very well trained alarm installers that work for him and that if he couldnt solve it then I would not be able to. He also stated that he removes alarm systems from bikes all the time as the boards etc just break. Sounds very umm… well trained…

Ok I had my new battery fitted and the alarm was left connected working correctly still. All was fine for a week or two. Oh wait my warranty did not cover batteries I had only bought it 6 months ago. Oh wait my warranty has just expired last week damn!

I didnt want to take it back to the garage as they seem to guess what the issue is and not actually fault find.

Triumph Speed Four

It had been very windy and my alarm was always beeping and going off in the night and hadnt used it for about another week so I thought maybe it would be flat but no it was perfectly fine. I was then going to my dads on boxing day but thought Id go the longer way through Bournemouth to give the battery a little more charge and a better run. The bike decided to cut out and stuttered as I pulled away at some traffic lights.

I tried starting the bike and no luck… click. click. sounds like a flat battery.

So a lad pulls over with his girlfriend and says do you want a push. I was like yeah sure, thanks. He then pushed me whilst I tried to start the bike how I did last time. The bike sounded like it was back firing and almost starting but just couldnt get it to start even rolling down the hill with him pushing.

I then spoke to my dad and he came down and connected jump leads to my bike and followed me home as all the indicators and speedo was flashing randomly and the bike was a bit stuttery.

I then read the plenty of information on the following websites and forums:

I came up with an idea to check the regulator rectifier on my bike for any visible damage to the connectors or corrosion on the terminals etc. I found that one of the yellow cables from the alternator that goes to the regulator rectifier was looking a bit green from corrosion on the copper and it was slightly burnt brown and looked like it may have got hot at some point.

I have now purchased a new piece of cable to solder on and connect to a new spade bit for the connector. I will also find some lubricant for the terminals to prevent corrosion.

This will be updated soon. I only posted this on the 29/12/2011 and will let you know how I get on.

Triumph Speed Four
Triumph Speed Four
Triumph Speed Four
Triumph Speed Four
Triumph Speed Four


Interesting articles

Tagged as:

Other articles of the category "Triumph":

Translation
Our partners
Follow us
Contact us
Our contacts

dima911@gmail.com

Born in the USSR

423360519

About this site

For all questions about advertising, please contact listed on the site.


Motorcycles catalog with specifications, pictures, ratings, reviews and discusssions about Motorcycles.